CSV export format


New member
Is there a way to change the date separator for the CVS export?

Currently, I have a date field that is manually filled and also one using the date picker. The manual field is entered "06/08/2016". The date picker enters the field as "05-18-2017". When I view the data in DaDaBIK, both fields display as entered.

When I export the data to CSV the manually entered field remains "6/18/2016". The date picker field changes to "5/18/2017".

Your current DaDaBIK version​

You are using DaDaBIK version 11.3-Elba enterprise, installed on 02-02-2022 (installation code: 688552cc613a1c6b6), the latest version of DaDaBIK is 11.3-Elba released on 01-17-2022

PHP Version: 7.4.27
mysql version: 5.5.5-10.5.13-MariaDB
Web server: Apache/2.4.52 (codeit) OpenSSL/1.1.1m PHP/7.4.27
Client: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.99 Safari/537.36



Staff member
the way the dates are formatted should depend on your config $date_format parameter.
Buy maybe you are experiencing a different problem: are you reading the CSV with a text editor or with Excel (or similar software)? If you are using Excel, maybe the / separator is applied because it recognizes a date field.



New member
Thank you, Eugenio! You are correct! I was exporting the CSV and using excel to manipulate the data. As a test, I opened the data in Notepad instead. The formatting is as it should be.